OpenRoads Designer CONNECT Edition SDK Help

StrokeByConnectionPoints(ConnectionPointTypes, LinearPointCollection) Method

Strokes the complex element by its control points. The resulting collection contains the the connection points merged with points of the linearPoints arguments.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPointCollection StrokeByConnectionPoints( ConnectionPointTypes types, LinearPointCollection linearPoints)

Parameters

SettingDescription
  ConnectionPointTypes Type of control points.
  LinearPointCollection Collection of points.

Return Value

LinearPointCollection Collection of points.

See Also